O2 UK service is down
Incident Report for Trakm8
Resolved
This incident has been resolved.
Posted Jul 01, 2020 - 14:22 BST
Monitoring
The MNO has provided an update that services have returned to normal.

This is now in a monitoring phase.
Posted Jul 01, 2020 - 12:30 BST
Investigating
Please be aware that we are investigating an O2 UK service interruption with the MNO.


We will update you as soon as possible with the next update.
Posted Jul 01, 2020 - 12:09 BST
This incident affected: M2M Cellular Connectivity (O2).